RB 450G รวมสัญญาณเน็ต 3เส้น STATIC

MikroTik RB450G เป็นอุปกรณ์ประเภท อุปกรณ์ Heavy Load Router วันนี้จะมาแนะนำการ รวมเน็ตจาก ISP แบบ router aircard 3 G ชนิด ใส่ ซิม

1468669_682010361823629_1168481497_n

โดยปกติแล้ว ระบบ บริการ 3G ปัจจุบัน ไม่ว่าจะเป็น ais datac true หรือ cat 3g จะเป็นชนิดจำกัดความเร็ว เช่น ใช้3g แบบความเร็วสูง แต่เมื่อหมดแพ็คเก็ตความเร็วจะลดลง 128kbps 384kbps ในสำนักงาน หรือ บางที่มีความจำเป็นที่จะต้องใช้สัญญาณเน็ตความเร็วสูง ซึ่งยกตัวอย่างผม  ต้องทำการเปิดซิม cat ไว้หลายๆซิม เมื่อเพ็ตเก็ตหมดต้องเปลี่ยนซิม แรกๆต้องใช้ถึง 4 ซิม รายจ่ายแต่ละเดือนก็ไม่ตำกว่า 2000 บาท ดังนั้น ผมจึงนำ MikroTik RB450G และซื้อ router3G ใส่ซิม เพิ่ม 2 ตัว และของเดิม 1 ตัว จึงได้รวมกัน 3 ตัว

4wan1lan-copy

วิธีการตั้งค่า LoadBalance RB450เ แบบ 3WAN(Static IP) to 2LAN ใช้กับ router ใส่ซิม

1.ดาวน์โหลด Winbox แล้วเสียบสาย LAN ขา Ether5 ของ MikroTik

เข้าโปรแกรม Winbox แล้วคลิกเลือก mac address MikroTik ที่ broadcast เจอ แล้วกด Connect

 

001

2.ปกติแล้ว MikroTik แทบทุกรุ่นจะมี config default ให้ แต่เราจะไม่ใช่ครับ กด Remove Configuration ได้เลย

 

004

3.RB450G จะทำการ Remove config default ออก แล้วจะ reboot ตัวเอง ถ้าเกิด message เด้งขึ้นมา ก็ไม่ต้องตกใจน่ะครับ

005

4.เนื่องด้วยถ้าทำในรูปแบบ Interface นั้นจะต้อง Capture หน้าจอเยอะมาก ผมจึงขอเปลี่ยนไปใช้วิธี code ผ่าน Terminal น่ะครับ เพราะรวดเร็วกว่า กว่า กด อะไรก็ไม่รู้หลายขั้นตอน เอา โค๊ดของผม copy แล้ววาง ซะ โดยเข้าเมนู New Terminal > Terminal

code นี้ ดัดแปลง จากเว็บ sys2u ที่ใช้ แบบ dynamic เอามาแปลง เป็น static ครับ

จะเห็นได้ว่า port ที่ 1-3 เป็นตัว input รับ ip มา ใน rang ที่กำหนด

คือ port  ที่ 1 คือ   192.168.2.2/24  และ   192.168.2.0  host id

port ที่ 2  คือ 192.168.2.3 /24 และ   192.168.3.0  host id

port ที่ 3  คือ 192.168.2.4 /24 และ   192.168.4.0  host id  วิธีการดังกล่าว จะช่วย การป้องกันการชนกัน ของ ip ในอนาคตได้

และเมื่อรวมกันแล้ว

ให้ port ที่ 5 เป็นสัญญาณ ออก ครับ   ในวง 192.168.1.1

ส่วนบรรทัดหลังจากนั้น เป็นการ chine mode ตามหลักการ Linux ครับ

#|

#|

#| Define all parameters

#|

#|

:global wanAddress1 192.168.2.2/24

:global wanNetwork1 192.168.2.0

:global wanNetwork1Subnet 192.168.2.1/24

:global wanBroadcast1 192.168.2.255

:global wanGateway1 192.168.2.1

:global wanAddress2 192.168.3.2/24

:global wanNetwork2 192.168.3.0

:global wanNetwork2Subnet 192.168.3.1/24

:global wanBroadcast2 192.168.3.255

:global wanGateway2 192.168.3.1

:global wanAddress3 192.168.4.2/24

:global wanNetwork3 192.168.4.0

:global wanNetwork3Subnet 192.168.4.1/24

:global wanBroadcast3 192.168.4.255

:global wanGateway3 192.168.4.1

:global localAddress 192.168.1.1/24

:global localNetwork 192.168.1.0

:global localNetwork2 192.168.1.0/24

:global localBroadcast 192.168.1.255

:global localGateway 192.168.1.1

:global localDNS 192.168.1.1

:global localPool 192.168.1.10-192.168.1.150

:global dnsServer 8.8.8.8,8.8.4.4

#|

#|

#| Assign interace’s name

#|

#|

/interface set “ether1″ name=”PORT1_WAN”

/interface set “ether2″ name=”PORT2_WAN”

/interface set “ether3″ name=”PORT3_WAN”

/interface set “ether4″ name=”PORT4_LAN”

/interface set “ether5″ name=”PORT5_LAN”

#|

#|

#| Assign master port switch

#|

#|

/interface ethernet set PORT5_LAN master-port=PORT5_LAN

#|

#|

#| Assign ipaddress to our interfaces

#|

#|

#| Port 1 -> WAN 1

/ip address add address=$wanAddress1 network=$wanNetwork1 broadcast=$wanBroadcast1 interface=PORT1_WAN

#| Port 2 -> WAN 2

/ip address add address=$wanAddress2 network=$wanNetwork2 broadcast=$wanBroadcast2 interface=PORT2_WAN

#| Port 3 -> WAN 3

/ip address add address=$wanAddress3 network=$wanNetwork3 broadcast=$wanBroadcast3 interface=PORT3_WAN

#| Port 4 -> Local LAN

#| Port 5 -> Local LAN

/ip address add address=$localAddress network=$localNetwork broadcast=$localBroadcast interface=PORT5_LAN|

#| Mark incoming package on input’s chain

#|

/ip firewall mangle add chain=input in-interface=PORT1_WAN action=mark-connection new-connection-mark=PORT1_WAN_conn

/ip firewall mangle add chain=input in-interface=PORT2_WAN action=mark-connection new-connection-mark=PORT2_WAN_conn

/ip firewall mangle add chain=input in-interface=PORT3_WAN action=mark-connection new-connection-mark=PORT3_WAN_conn

#|

#| Mark routing package on output’s chain

#|

/ip firewall mangle add chain=output connection-mark=PORT1_WAN_conn action=mark-routing new-routing-mark=to_PORT1_WAN

/ip firewall mangle add chain=output connection-mark=PORT2_WAN_conn action=mark-routing new-routing-mark=to_PORT2_WAN

/ip firewall mangle add chain=output connection-mark=PORT3_WAN_conn action=mark-routing new-routing-mark=to_PORT3_WAN

#|

#| Accept all packages if they come from local

#|

/ip firewall mangle add chain=prerouting dst-address=$wanNetwork1Subnet action=accept in-interface=PORT5_LAN

/ip firewall mangle add chain=prerouting dst-address=$wanNetwork2Subnet action=accept in-interface=PORT5_LAN

/ip firewall mangle add chain=prerouting dst-address=$wanNetwork3Subnet action=accept in-interface=PORT5_LAN

#|

#| Do the load balance package

#|

/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=PORT5_LAN per-connection-classifier=both-addresses-and-ports:3/0.5 action=mark-connection new-connection-mark=PORT1_WAN_conn passthrough=yes

/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=PORT5_LAN per-connection-classifier=both-addresses-and-ports:3/1.5 action=mark-connection new-connection-mark=PORT2_WAN_conn passthrough=yes

/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=PORT5_LAN per-connection-classifier=both-addresses-and-ports:3/2.5 action=mark-connection new-connection-mark=PORT3_WAN_conn passthrough=yes

#|

#| Mark output network for packages

#|

/ip firewall mangle add chain=prerouting connection-mark=PORT1_WAN_conn in-interface=PORT5_LAN action=mark-routing new-routing-mark=to_PORT1_WAN

/ip firewall mangle add chain=prerouting connection-mark=PORT2_WAN_conn in-interface=PORT5_LAN action=mark-routing new-routing-mark=to_PORT2_WAN

/ip firewall mangle add chain=prerouting connection-mark=PORT3_WAN_conn in-interface=PORT5_LAN action=mark-routing new-routing-mark=to_PORT3_WAN

#|

#| Add routing table

#|

/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway1 routing-mark=to_PORT1_WAN check-gateway=ping

/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway1 distance=1 check-gateway=ping

/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway2 routing-mark=to_PORT2_WAN check-gateway=ping

/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway2 distance=2 check-gateway=ping

/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway3 routing-mark=to_PORT3_WAN check-gateway=ping

/ip route add dst-address=0.0.0.0/0 gateway=$wanGateway3 distance=3 check-gateway=ping

#|

#|

#| Assign NAT

#|

#|

/ip firewall nat add chain=srcnat out-interface=PORT1_WAN action=masquerade

/ip firewall nat add chain=srcnat out-interface=PORT2_WAN action=masquerade

/ip firewall nat add chain=srcnat out-interface=PORT3_WAN action=masquerade

#|

#|

#| Assign allow DNS

#|

#|

/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=$dnsServer

#|

#|

#| Assign DHCP server

#|

#|

/ip pool add name=default-dhcp ranges=$localPool

/ip dhcp-server add name=default address-pool=default-dhcp interface=PORT5_LAN disabled=no

/ip dhcp-server network add address=$localNetwork2 gateway=$localGateway dns-server=$localDNS

img20131201002

 

 

หลังจาก copyและ paste ให้ ไปที่ หัวข้อ system > reboot  1 ครั้ง ก็ถือว่าเป็นอันใช้ได้ครับ สงสัยสอบถามมาที่ nattanon_idep@hotmail.com  ครับ  อันนี้ไปติดที่บ้านผมครับ ทั้งหมดเป็น router 3 g ของ cat  ครับ

1486695_683832344974764_329394410_n

ทดสอบให้เห็นเลย ว่า ได้ 8 mb ทั้งที่ ซิม 3 g ได้ต่อตัว ไม่เกิน 8 mb (พื้นที่ทดสอบ ห่างจากชุมสายโทรศัพท์ บ้าน และอินเตอร์เน็ต 17 กม ครับ )

nattanon

ณัฐนนท์ ลำสมุทร

Leave a Reply

Your email address will not be published. Required fields are marked *